My 2inch mortar is FUBAR!

I’ve researched and bought the ATR-boys AT-gun (For dailies), and have finished the 2inch mortar. Now it says I can’t buy it or use the unit. While it’s a buggy unit it sounds fun. It says I lack the predecessors to the mortar, any idea what I’m missing to use this? I’m close to tommy guns but it didn’t feel right to jump out of tier 3’s equipment. I do have a few skipped items from since my death/coma, so any idea what I need to do to use this would be great!

Can you screenshot the tech tree to provide a visual of the situation?

It’s not threw steam, so no clue how? I’m sorry as along with dieing I had a major stroke due to my deadly heart attack… I FEEL DUMB now I was a very techy guy.


If you can download this app from the Microsoft store, you can press the “print screen” button on your keyboard and it will screenshot.

I’m sorry to hear that :frowning: . Is recovery getting better for you?

1 Like

My medical stopped my physical therapy before it could work so not really? Mortar|1000x560
As of now I play this, wows and warthunder which are all really hard with my gimp hand(Not perm but a great ice breaker!)

I’m sorry to hear that bro. Glad it is not perm though.

I have never seen this issue before @Euthymia07

When I click on the image I get this


yep same

1 Like

The same happened to me. I tried opening it in a private window, and it worked.

@Devenddar Have you ever seen this happen to someone?


oh maybe he have to buy it first? that would be my guess but since im no where near any unlock right now i cant test it

same thing seem to be happening with M1917 Enfield up there too so maybe the game force you to buy it, but only the helper knows tbh

1 Like

Probably forum bug. You can still open it as a separate window, but not by clicking on it.

No, I mean in the tech tree from the screen shot. Have you ever seen the tech tree lock up on someone?

Stupid question here, sorry…are you sure you bought the Boys AT with the squad?
Coz yours still says 500S but mine has a shopping cart, I have the squad for sure.
But I had it before the merge, I dont know if makes a difference.
Also: your Boys AT icon is green, while mine is grey.
So either you didnt buy it yet, it there is a bug.
Tried logging out and in again?

1 Like

Yes as I have 2 set groups using them. As for the pict I snapped it and just uploaded it. I can’t use the app you mentioned as I have no print screen on my laptop.
Sorry all.

Figured it out, I had the ATR before I died, and in an update my old buys of the ATR did not carry over. What a crazy bug, thanks for the idea guys!

1 Like

I dont understand how you got it fixed, but I’m glad it’s fixed.
I also dont understand your medical situation, but I wish you well.

1 Like

A bad covid shot stopped my heart, giving me a stroke, and a 3 year coma. The stuck a tube in my neck wrong, so now I have a paralyzed vocals cords, so can’t talk. They taped my left hand in metal semi, casts, so can’t really move left hand. If you want more PM me.

1 Like

so enlisted basically force us to buy these thing before we can buy the one we want? dam i guess i have to buy all those tank that i farm but didnt buy on my way to Tiger 2 sad man

if you bought them pre-merge … it does come with a squad. If that squad is no longer the same as the one you have. That would mean you need to buy the squad (the new one that is in the tree). There were many squads like this right after the merge that people had to buy. It comes with the 68th Anti-Tank Regiment … See if you have that squad in your collection. If its not in your collection, that is why and its not a bug. You just need to pick up the squad first.