Custom Game Softlocking

Apparently whenever I start up my Russian Civil War mod, I am met with the loading screen and my cursor stuck in the middle. The mod never loads, it stays in an infinite loop and is softlocked.

Any solution to this issue? Or at least a reason as to why this is happening?

too much data is trying to be loaded.

in my case, i removed some scenary remover ( as… there were too many for what i was needing ), tweak a few things ( like removing AI soldiers. but i doubt you use them and shrink the ammount of vehicles ) and it worked.

unfortunately, don’t know much about your case.

perhaps he can help you @Devenddar

but you’ll have to give him through dms your files and what not.

1 Like

I’ll try removing some stuff, and do some experimenting. Thanks for the help.

It’s probably some problems with UI. And it don’t show “connection failed” or something like it (like when you use wrong armies).

If you sure that you don’t use wrong armies then it can happends because of wrong entities or veeery many scenery removers. Would be good to see some code.

1 Like

Alright here it is: (33.5 MB)

Also apparently they fixed the Fatal Exception error bug, the issue has been closed.

1 Like

Well… After short look… I’m not sure… But probably because of scene. I’ll try to look into this more deeply later.

I see that you still not use seperate blk file for gun__blk. So your mod probably will have some problems with weapon pickup/drop. Also you have many battle areas. It reduces the server launch speed.

1 Like

Alright well I’ll get to work on the gun__blk thing.

Although I do find it strange, since my Pancho Villa mod has a much larger scene.blk file and works just fine.

I’m guessing I just have too much stuff, I’ll take a look at my files and try to cut down on memory

Found out that the mod only soft locks on NA servers.

Hooo… Only there? Weird. Seems bug with servers…

1 Like

It appears so, yes.

Update: Apparently the game keeps soft locking, unless you change your game mode to practice before entering custom lobbies.

This is very strange.

Will submit a report to Gaijin later, but not rn since I’m not on computer rn.